MATLAB Answers

Fedora 30 Matlab Not Installing

111 views (last 30 days)
Patrick Gorman
Patrick Gorman on 24 Oct 2019
Edited: Patrick Gorman on 25 Oct 2019
I'm running fedora 30 and attempting to install the latest version of Matlab.
When I run the installer, I get the following output
$ sudo ./install
Preparing installation files ...
Installing ...
Finished
However, I do not get any popup, and matlab does not appear to be installed.
I have installed libxcrypt-compat and libnsl, but matlab is still not installing properly.

  0 Comments

Sign in to comment.

Answers (1)

Patrick Gorman
Patrick Gorman on 25 Oct 2019
Edited: Patrick Gorman on 25 Oct 2019
Answered my own question. The Matlab Installer does not launch in the Gnome Desktop environment on Fedora 30, so you must use another Desktop Environment. Once it is installed, you may launch matlab directly from Gnome.
I found that the installer works in the xfce desktop environment. In order to installl xfce, I did the following:
  1. Install requirements and Xfce
sudo dnf install libxcrypt-compat libnsl
sudo dnf groupinstall -y "Xfce Desktop"
2. Restart computer
3. In window to enter password, click the settings logo below password bar and select to boot into Xcfe
3. Go to .../matlab-installation-directory and run install
cd /path/to/matlab-installation-directory
sudo ./install
4. Follow install wizard as normal.
Optional:
5. Remove Xfce Desktop Environment
sudo dnf groupremove -y "Xfce"
sudo dnf remove -y libxfce4*

  0 Comments

Sign in to comment.

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!