Question on using geometryFromMesh

5 views (last 30 days)
Hi all,
I came across a problem when using geometryFromMesh. I have a mesh file for a 3D geometry generated from COMSOL, and I would like to use it in pde toolbox in MATLAB. The COMSOL file contains the coordinates for the nodes, which is a Nnodes-by-3 matrix and the element information which is a Nelements-by-4 matrix. I rearranged the node matrix and element matrix, and put them in the form in 3-by-Nodes form and 4-by-Nelements form as indicated in https://www.mathworks.com/help/pde/ug/pde.pdemodel.geometryfrommesh.html#buvjb86-nodes
However, there is still a warning saying that there is node ID missing and it should start from 1. However, if I add a row for node ID the matrix will not be 3-by-Nodes.
Is there anything that I missed that caused this problem?
Than you very much!
Best regards,
Shengyue

Accepted Answer

Ravi Kumar
Ravi Kumar on 21 Nov 2019
It looks like the node IDs from COMSOL might be 0 based. That is first node ID in COMSOL may be 0, in MATLAB it must be 1. You can check this by:
min(elementMatrix,[],'all')
If the answer is 0, then you need to just add 1 to elementMatrix:
elementMatrix = elementMatrix+1;
Regards,
Ravi
  1 Comment
Shengyue Shan
Shengyue Shan on 21 Nov 2019
Hi Ravi,
Thanks for your answer! It works!
Best regards,
Shengyue Shan

Sign in to comment.

More Answers (0)

Products


Release

R2018b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!