MATLAB Answers

Calling curl from within Matlab

133 views (last 30 days)
Jonas_Carlson
Jonas_Carlson on 28 Sep 2012
Answered: Michael McClung on 24 Oct 2020
I have a number of datafiles to be processed. They should be sent to a server, processed, with the results being further processed in Matlab.
I am using curl to communicate with the server using: reply = evalc('!curl https://... -H ... -d ...') and I get the result: curl: (1) Protocol https not supported or disabled in libcurl
I am using Matlab R2012a running under Linux (Fedora 17). When I try the exact same command in a terminal window, it works just fine. Also, this exact program worked before I upgraded Matlab from a previous version (2010).
As I need to use the -H and -d switches of curl I (think) I cannot use "urlread".
What is the difference between using curl in a terminal and invoking it via "!" or "system" from Matlab?
/Jonas Carlson
  2 Comments
Jonathan
Jonathan on 6 Jul 2013
I have the same problem. Has anyone found a fix? Thanks.

Sign in to comment.

Answers (5)

Christopher
Christopher on 5 Jan 2013
Can't you just use a system call?
[A,cURL_out] = system('curl http://www.google.com')
  1 Comment
Walter Roberson
Walter Roberson on 5 Jan 2013
That would do the same thing as evalc('!curl...')

Sign in to comment.


Pär Halje
Pär Halje on 5 Sep 2013
Hi
Apparently the version of libcurl that is bundled with Matlab does not support https. I found a somewhat cumbersome solution here:
This solution is written for Mac so you need to get your libcurl library from somewhere else than MacPort...
Or maybe libcurl is updated in a newer matlab version?
Pär

M. A. Hopcroft
M. A. Hopcroft on 17 Sep 2013
I had the same issue with Linux (Ubuntu) and R2012a, and solved it by changing the libcurl link in the MATLAB application libraries to point to the system libcurl.
The MATLAB application directory looks like this after installation:
/usr/local/MATLAB/R2012a/bin/glnxa64$ ll libcur*
lrwxrwxrwx 1 root root 16 2012-06-18 18:12 libcurl.so.4 -> libcurl.so.4.2.0*
-r-xr-xr-x 1 root root 320452 2011-12-29 00:33 libcurl.so.4.2.0*
The link in the system library directory is pointing to libcurl.so.4.1.1, which was built with https support:
/usr/lib$ ll libcurl*
lrwxrwxrwx 1 root root 19 2013-07-12 14:22 libcurl-gnutls.so.3 -> libcurl-gnutls.so.4
lrwxrwxrwx 1 root root 23 2013-07-12 14:22 libcurl-gnutls.so.4 -> libcurl-gnutls.so.4.1.1
-rw-r--r-- 1 root root 274368 2013-06-27 12:32 libcurl-gnutls.so.4.1.1
lrwxrwxrwx 1 root root 12 2013-07-12 14:22 libcurl.so.3 -> libcurl.so.4
lrwxrwxrwx 1 root root 16 2013-07-12 14:22 libcurl.so.4 -> libcurl.so.4.1.1
-rw-r--r-- 1 root root 295360 2013-06-27 12:32 libcurl.so.4.1.1
So I changed the softlink:
/usr/local/MATLAB/R2012a/bin/glnxa64$ sudo ln -s /usr/lib/libcurl.so.4.1.1 libcurl.so.4
This fixed the problem for me and has not caused any unintended consequences in MATLAB (so far).
>> system('curl -V')
curl 7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15
Protocols: tftp ftp telnet dict ldap ldaps http file https ftps
Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz

amjad majid
amjad majid on 21 Apr 2015
The way I solved this is as follows:
1- go to /Applications/MATLAB_R2015a.app/bin/maci64 2- rename libcurl.dylib to libcurl-OLD.dylib 3- rename libcurl.4.dylib to libcurl.4-OLD.dylib 5- make a symbolic link form to the libcurl from the operating system sudo ln -s /usr/lib/libcurl.4.dylib libcurl.4.dylib sudo ln -s /usr/lib/libcurl.dylib libcurl.dylib
Hopefully that would help

Michael McClung
Michael McClung on 24 Oct 2020
Another workaround is to prepend LD_LIBRARY_PATH="" in front of curl:
system('LD_LIBRARY_PATH="" && curl <args>')
This seems to work for me and does not require modification of installed MATLAB libraries.
On OSX this will probably need to replace LD_LIBRARY_PATH with DYLD_LIBRARY_PATH. However, I have no way to test.

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!