The CUDA driver must recompile the GPU libraries

224 views (last 30 days)
Jianyu Zhao
Jianyu Zhao on 8 Jan 2021
Commented: Jianyu Zhao on 12 Jan 2021
Hi everyone, I'm now using MATLAB 2020a, when I tried to train the CNN, I met a warning: The CUDA driver must recompile the GPU librariesbecause your device is more recent than the libraries. Recompiling can take several minutes.
My GPU is RTX 3090, I have checked my CUDA driver and reinstalled the CUDA10.1 driver, I also tried MATLAB 2020b version, but the warning still exist.
Can anyone help me? Thanks a lot!

Accepted Answer

Joss Knight
Joss Knight on 10 Jan 2021
There isn't really much to say. This 'forward compatibility' is explained in the CUDA support by release documentation. As it says, just allow the NVIDIA driver to compile, and when it's done, that should be it. You may need to increase the CUDA_CACHE_MAXSIZE environment variable, if you find this compilation is happening repeatedly.
The warning will continue to be displayed once per session, even if you experience no compilation. You can just suppress that warning if you don't want to see it.
  7 Comments
Jianyu Zhao
Jianyu Zhao on 12 Jan 2021
Okay Thanks Joss Knight, I understand. I will try other ways to do my research and wait for the version which could support Ampere. Thank you for you reply!

Sign in to comment.

More Answers (0)

Products


Release

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!