MATLAB Answers

Problem with Simscape Onramp task 9

37 views (last 30 days)
Juan Manuel Ruiz Martíez
Juan Manuel Ruiz Martíez on 30 Mar 2021
Commented: Joel Van Sickel about 5 hours ago
Hello, I can´t answer the last task, task 9, of the section 8.1 of the simscape onramp course, I do exactly what I´m requested to do but I always get it wrong, I´ve been for several hours trying it but I simply don´t understand what I´m getting wrong. I´ve looked for the answer on Youtube but literally nobady has upload it, at least I haven´t found anybody, does anybody knows how to obtain the answer or can anybody tell me where can I find the way to solve it?, thank you!

Answers (1)

Joel Van Sickel
Joel Van Sickel on 6 Apr 2021
Hello Juan,
can you provide insight into what is says is going wrong? There are 2 validation check marks that need to be passed for this one. Did you modify your PID controller to only be a PI controller (look for a drop down box). It can be solved.
  7 Comments
Joel Van Sickel
Joel Van Sickel about 5 hours ago
anyone on this thread, if you are still having issues, can you take a screen shot of what your scope output is? This will show if the model is running as expected. It should look something like this:
John, your issue is that there the connection between the inertia should not also be connected to the rotational reference. This is essentially locking the rotor in place.

Sign in to comment.

Tags

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!