MATLAB Answers

Simulink unable to load bundle binary

75 views (last 30 days)
Johnny Hung
Johnny Hung on 21 May 2021
Answered: HiWave on 26 Jul 2021
I recently upgraded my workstation to Alma Linux (a fork of RHEL8) and installed MATLAB R2020b. MATLAB works fine but when I try to use Simulink I get the following error:
Unable to load bundle binary /usr/local/MATLAB/R2020b/bin/glnxa64/builtins/sl_graphical_classes/mwsl_graphical_classes_builtinimpl.so.
Error: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b: Success
I found some thread of people having similar errors (not necessary with Simulink though) and they were able to solve it by removing the copy of libcrypto.so.1 which comes with MATLAB (<MATLABROOT>/bin/glnxa64/libcrypto.so.1.1) then creating a symbolic link which points to the libcrypto.so.1 from the OS itself (/lib64/libcrypto.so.1.1). When I tried that, MATLAB would open and then immediately close with the following error:
*** buffer overflow detected ***: /usr/local/MATLAB/R2020b/bin/glnxa64/MATLAB terminated
Segmentation fault
Has anyone seen this before? Any advice would be much appreciated.
  1 Comment
HiWave
HiWave on 26 Jul 2021
I'm having the same issue:
Unable to load bundle binary /bin/glnxa64/builtins/sl_graphical_classes/mwsl_graphical_classes_builtinimpl.so. Error: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b: Success
Linux RHEL 8.3
Matlab 2020b
I've uninstalled by removing everything (installed directory and .matlab directory). Following reinstall, it still didn't work.

Sign in to comment.

Answers (1)

HiWave
HiWave on 26 Jul 2021
OK...this isn't necessarily THE solution, but it does appear to solve my problem. I started by removing the files
rm -rf <MATLABROOT>/bin/glnxa64/libcrypto.so.1.1*
in order to install Matlab (solves install issues). In this case "<MATLABROOT>" is the directory where you're running the installer from. After it installs, Matlab should start up without a problem. At the Matlab command promt, type in "simulink" (or launch from icon) and it will fail with the error shown above.
The solution appears to be that you need to remove the libcrypto.so.1.1* files POST installation as well. I don't know much about the install process, but again, this worked for me. Go to where you installed Matlab. It will also contains a "/bin/glnxa64/" directory structure. Inside there, you need to remove the files
rm -rf <MATLABROOT>/bin/glnxa64/libcrypto.so.1.1*
in which "<MATLABROOT>" is the installation directory, not where you ran the installer from. Simulink now starts.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!