MATLAB Answers

Why do I get an error saying "Undefined function or variable 'matlabrc'" when executing a program that uses a MATLAB-compiled shared library?

389 views (last 30 days)
I am trying to use a MATLAB-compiled shared library in a C++ program. There are no issues when I use the same code with the libraries compiled using MATLAB Compiler 4.7 (R2007b). However, when I recompile all the MATLAB libraries using MATLAB Compiler 4.9 (R2008b) and then try to execute the same program, the <libName>Initialize() function fails with the following error:
??? Undefined function or variable 'matlabrc'

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 30 Apr 2020
Edited: MathWorks Support Team on 30 Apr 2020
This change has been incorporated into the documentation in MATLAB Compiler 4.11 (R2009b). For previous releases, read below for any additional information:
Starting MATLAB Compiler 4.8 (R2008a), CTF data is now automatically embedded directly in the C/C++, main and Winmain, shared libraries and standalones by default. In order to override this default functionality, you must compile with the -C 'Do Not Embed CTF Archive By Default 'option.
Since the MATLABRC script is usually included in the CTF archive, you may receive this error if the application is unable to find the CTF archive. Conventionally, some application build procedures strip all binary files involved in the process. If the embedded CTF archives in shared libraries are stripped in this process, the driver application may not be able to find the CTF data during execution.
If your application build process performs such a process, please compile with the -C 'Do Not Embed CTF Archive By Default 'option.
Another workaround here is to delete the CTF extraction folder, and run the EXE again. If the MCR_CACHE_ROOT environment variable is not set, the CTF extraction location can be found at:
If neither of these resolves the issue, follow these additional troubleshooting steps, previously found at :
1) Ensure that your application runs in MATLAB (uncompiled) without this error.
2) Ensure that MATLAB starts up without this error.
3) Verify that the generated deployable archive contains a file called matlabrc.m
4) Verify that the generated code (in the * _mcc_component_data.c * file) adds the deployable archive folder containing matlabrc.m to the MATLAB runtime path
5) Delete the *_mcr folder and rerun the application.
6) Recompile the application.


Sign in to comment.

More Answers (2)

Patrick Rollin
Patrick Rollin on 15 Oct 2014
I've had this issue arise from a perfectly working Matlab executable via MCR2013a (v8.1)... and one day it stopped working.
I solved the issue (for Windows 7 64bit) by:
1) deleting the Matlab Runtime Compiler temporary cache folder.
2) re-ran the executable manually to rebuild the required cache folder.
Every time this issue re-arises I simply repeat these 2 steps and I'm back in business.


Show 6 older comments
KAE on 29 Apr 2020
This needs to be in the documentation, in a location that users can easily find it. I would have been in real trouble without your answer.

Sign in to comment.

Michael Haitz
Michael Haitz on 27 Sep 2018
I had the same problem with a dll generated with Matlab Compiler R2015b. After adding matlabrc.m to the m-file list of my compiler command line, the problem seems to be solved.


Hazel on 21 May 2019
can you give more information on how you add matlabrc.m to the m-file list of the compiler please? Is this through 'Add a file/folders' to the 'Package' or the 'Shared Resources and Helper Files' within 'Build'?
And is it the matlabrc.m the one from the appropriate MATLAB version such as "C:\Program Files\MATLAB\R2012b\toolbox\local\matlabrc.m"?
Thanks very much
Michael Haitz
Michael Haitz on 21 May 2019
The version from "C:\Program Files\MATLAB\R2012b\toolbox\local\" should be the correct one.
I use the mcc compiler to generate a dll file from my m-files. I just put matlabrc.m in the list of m-files in the command line, e.g.:
"mcc -v -B csharedlib:Main Main.m matlabrc.m file1.m file2.m VerInfoMainXMLS.res"
Then the error disappeared.

Sign in to comment.


No tags entered yet.