Hardware Support

iPhone and iPad Sensor Support from MATLAB

Use MATLAB to acquire accelerometer, magnetometer, gyroscope, and location data from built-in sensors on your iPhone or iPad.


Explore gallery (2 images)

MATLAB® supports the acquisition of data from the built-in sensors on Apple® iPhone™ and iPad™. With the MATLAB Support Package for Apple iOS Sensors, you can log data or query the most recent data available from the supported sensors on your Apple iPhone or iPad. These include motion sensors like the accelerometer and position sensors like the GPS. Measurements such as acceleration, magnetic field, latitude, longitude, and altitude can be viewed on your iPhone, iPad, or other iOS device. You can then analyze the data in MATLAB or build applications that make decisions based on the sensor data. To use this package, you must also install MATLAB Mobile™ on your iPhone or iPad.

The MATLAB Support Package for Apple iOS Sensors lets you acquire and log data from the supported iPhone or iPad sensors to obtain the indicated measurements:

  • Acceleration on 3-axes
  • Magnetic field on 3-axes
  • Angular velocity on 3-axes
  • Azimuth, roll, pitch
  • Latitude, longitude, altitude, horizontal accuracy, speed, and course

Platform Support

Available on 64-bit Microsoft® Windows®, 64-bit Mac OS X, and 64-bit Linux®.

Join the Community

Ask a question or share your files with the MATLAB community.


Related Hardware Support Views: MATLAB, Apple, Ethernet, MathWorks Supported, MATLAB Product Family, Support Package Installer Enabled, Test and Measurement

Ready to install?

Before installing the support package, confirm you have the correct setup. View system requirements and installation options.

Get support package

Software

Required

Recommended

Support Package

Required

Support Package Installer installs this support package and all required third-party software. To start the installer, go to the MATLAB toolstrip and click Add-Ons > Get Hardware Support Packages. For more information, read the documentation.

Get support package

Hardware

Required

  • iPhone, iPad, or iPod touch
    (iOS 7 or later)

Software

Required

All required third-party software is installed by the Support Package Installer.

Don't see the hardware you're looking for?