Main Content

NET.isNETSupported

Check for supported version of Microsoft .NET

Description

example

tf = NET.isNETSupported returns logical 1 (true) if a supported version of Microsoft® .NET is found. Otherwise, it returns logical 0 (false) and you cannot use .NET in MATLAB®.

MATLAB supports loading libraries compiled for .NET 5 and higher, .NET Core, and the Microsoft .NET Framework on the Microsoft Windows® platform only. For details, see System Requirements for Using MATLAB Interface to .NET. For information about .NET versions compatible with MATLAB, see MATLAB Interfaces to Other Languages.

For information about using the .NET environment in MATLAB, see dotnetenv and NETEnvironment.

Examples

collapse all

if ~NET.isNETSupported
    disp('Supported .NET interface not found')
end

Version History

Introduced in R2013a