sudo ./install doesn't start on Linux

202 views (last 30 days)
Domenico Notarangelo
Domenico Notarangelo on 9 Oct 2021
Edited: Robert Kirkby on 19 Jan 2022 at 2:53
I've downloaded zip file of MATLAB R2021b for linux and when i tried to use the command sudo ./install nothing happen, i've tried with sudo sh ./install but nothing. Terminal give me no messages and i don't know what to do but i need matlab on my pc. It seems like the file named install doesn't work, how can i solve?
  3 Comments
Joseph Zsombor-Pindera
Joseph Zsombor-Pindera on 3 Dec 2021
@Rik this worked for me too, thanks!

Sign in to comment.

Answers (2)

Tanmay Das
Tanmay Das on 12 Oct 2021
Hi,
To my understanding, you are not able to launch MATLAB R2021b in your linux terminal. The most likely reason is that you do not have permissions to one or more of the files in the installation folder. A similar question has been answered previously the link to which has been attached below. It might help you resolve your issue.
  1 Comment
Niladri Sekhar Mandal
Niladri Sekhar Mandal on 24 Nov 2021
I could not install 2021b, but could install 2020b without any setting changes. It seems there is a bug in the installer.

Sign in to comment.


David Wilby
David Wilby on 17 Nov 2021
I'm also having this issue on ubuntu linux 18.04 with R2021b. This seems like quite a critical failure for Linux users. Are there any plans to fix this bug in the installer?
  4 Comments
Robert Kirkby
Robert Kirkby on 19 Jan 2022 at 2:47
Same problem with R2021b on Kubuntu 20.10:
./install runs fine but obviously can't install to /usr/local/ as don't have access privelidges
sudo ./install the gui never appears (nothing happens, the command line claims to be running the installer when I quit it)
(can install R2021a just fine)

Sign in to comment.

Products


Release

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!