MATLAB Answers

Problem with machine initialization and wrong steady state voltages in simpower systems

2 views (last 30 days)
J Gunda
J Gunda on 29 Oct 2014
Answered: Joel Van Sickel on 2 Jul 2021
I have simulated IEEE-14 bus system in the simulink taking the generators as voltage sources. Regarding normal power flow it was worked fine and have compared the results with other software also. I have also checked the branch currents and power flows, they were matched with other software.
But the problem is: When I replaced the normal voltage sources with exact synchronous machine blocks the solution is entirely different and indeed its the worst solution. When I was trying to do machine initialization the powergui block is unable to do it most of the times and; even if it do it wrongly initializing the machine variables: for example my generator is 11KV (RMS)---but after initialization it is showing Vab, Vbc, Vca neither they are equal to 11KV nor they have balanced.
And when I was checking the steady voltages of the sources, loads and branches from powergui blocks they are not equal to their rated voltage (at least not near to that).
And more thing is when I am doing fault analysis the three phase fault at generator the fault current is somehow ok but with L-G fault current is too low. Actually L-G fault at generator terminals is more severe compared to LLL fault.
I am very confusing, how the things are going on in simulink.
Any comments and suggestions greatly appreciated. Thanks, Jagadeesh

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!