MATLAB Answers

Can I download installation files for the Embedded Coder® Support Package for AUTOSAR Standard?

I would like to download the Embedded Coder® Support Package for AUTOSAR Standard now when I have internet access but install it later when I do not have internet access.

  0 Comments

Sign in to comment.

4 Answers

 Accepted Answer

The Embedded Coder® Support Package for AUTOSAR Standard installation file links are provided below for download. Prior to R2014b, AUTOSAR support was provided with Embedded Coder and did not require a separate download. Once downloaded, you may install the support by following these instructions:
For R2015a to R2016a: Please follow these steps -
1. Unzip the downloaded file in a folder,
2. Launch support package installer,
3. Select "install from folder" option,
4. Browse to the folder where the downloaded file was unzipped, select the folder autosarstandard_download,
5. Continue the installation.
For R2016b and beyond : Please follow these steps -
1. Unzip the downloaded file in a folder,
2. Follow instructions given in the readme.txt
Links for download-

  0 Comments

Sign in to comment.


Answer by learner
on 15 Dec 2016
Edited by learner
on 15 Dec 2016

Hello, I am trying to control tms320f28335 using Matlab. I am using Matlab version 2012b, I found that Embedded coder tool package can be used for controlling DSP along with Code Composer. i looked up many times i couldn't find actual Embedded coder package .I tried above links but doesn't work. Is there anyway i could download the old version? i tried other links too but doesn't seem to work. Any suggestions and tips would be very much appreciated.
Thanks in advance.

  1 Comment

Provided that you already have a license for Embedded Coder for R2012b or some later release, you could try going directly to https://www.mathworks.com/downloads/web_downloads/select_products?dl_action=choose_products&platform_id=26&release_name=R2012b&tab=f (I assumed Windows 32 bit)
If you do not already have a license for Embedded Coder for R2012b or later, then it is no longer to purchase it against that release. In that situation, you would need to buy (or pay past-due maintenance service to restore) a current version of MATLAB; if you ended up purchasing a new license you would also need to purchase all the toolboxes you needed to use with Embedded Coder. You would then be able to use the new version (since you paid for it), or if you have compatibility reasons to keep using the old version, you would be able to download it, possibly from the link I posted above.
Note: if your license is a Student Version or Home license, then Embedded Coder is not available to you.

Sign in to comment.


Answer by Jose Lopes de Jesus on 21 Jun 2018

Hello I can not find the link to buy the Embedded Coder 7. Please can you help me? Thanks JJ

  0 Comments

Sign in to comment.


Answer by Juergen Bohn on 19 Jun 2019

We have installed the autosar addon in test environment for our software. The test machines are completely offline. For R2018a it turns out, that the installed autosar addon is out-dated in the sense, that our developers get different behavior when they install the addon interactively from their Matlab UI.
Can you provide an update for the autosar addon for R2018a, please?
It seems that it is not possible to find out, which version of an addon is installed. Are there any files in the installation that help us to identify, what (i.e. which version) has been installed?
Thanks in advance.

  2 Comments

The version number should be listed in Add-On Manager. You can use the Support Software Downloader to help distribute to the offline machine.
Thanks. I would like to give you some feedback with my experience.
(1) the Add-On Manager shows the "version 18.1.0". But for most version there exist several "updates". I can not get from the Add-On Manager, which update is installed. In particular, the online installation executed interactively from Matlab 2018a yields a different "update" than your link above
(2) Now I used your Support Software Downloader to get the AutoSar addon for EC. The downloaded readme.txt says:
"NOTE: The silent installation of support packages is only available in MATLAB releases R2018a and newer."
The attached screenshot (SilentInstallFail.JPG) shows that I called exactly what is explained in the readme.txt, but the SupportSoftwareInstaller.exe tries to access the internet, that is not reachable on my machine(s).
Only "C:\ProgramData\MATLAB\SupportPackages\R2018a\sppkg_matlab_info.txt" is created, then the dialog windows stays forever.
The interactive installer allowed me to do the installation. And by comparing the contents of C:\ProgramData\MATLAB\SupportPackages\R2018a I can now say that the installation is equal to the one that we get in online machines.

Sign in to comment.