MATLAB Answers


Getting error from xlsread

Asked by Armin Sadeghian on 17 Feb 2016
Latest activity Commented on by Kashif Mehmood on 25 May 2019
I am trying to run a code which used to work perfectly using previous versions of Matlab. Now after upgrading to version 2015b I receive this error at line 251 of xlsread.m
Anybody knows anyway to fix this?
thank you.


on 11 Apr 2016
I was encountering the same problem since long. I tried saving the excel file in 97-2003 format. And then xlsread worked well :-)
i tried this but still have problem

Sign in to comment.


4 Answers

Answer by xianjie Zhou on 17 Feb 2016
 Accepted Answer

What error message you got? I have the same problem, it saids: Error: The server threw an exception. But I run for second time it goes. I believe there are some solutions for that:

  1 Comment

When I check xlsread.m at line 251 I see the same error "threw exception".I reinstalled Matlab, but it did not solve my problem.

Sign in to comment.

Answer by XM Liu
on 17 Nov 2016

1- open the excel> file, >option, >add in, manage then select COM ADD IN, and clear everything (unchecked). everything should be cleared (unchecked). 2- restart the PC, and open the matlab. 3- perform xlsread command.
PS. For those people who use foxit pdf reader, it is potential to face this problem, so follow mentioned order.


Show 1 older comment
Thanks a lot! It solved my problem. It was actually the Foxit Reader COM ADD IN.
on 12 Nov 2018
Also worked for me. Such a weird bug with Foxit... Thanks XM Liu!
on 30 Apr 2019
Thanks Liu. It also worked for me with R2018a and Excel 2016.

Sign in to comment.

Answer by Seth Wright on 22 Oct 2018

Saving it as a csv file fixed it


Sign in to comment.