Simulink Real-time 2017a: Failure in slrttest (Test 4) with error message - LoadDLM: WriteFile Error. This was not an issue in 2016b why now?

6 views (last 30 days)
Upon upgrading to the latest release 2017a my Simulink real-time setup which has worked for many previous versions of Matlab has ceased working. When running slrttest it completes the first few tests succesfully and then fails during Test 4 giving the error message:
LoadDLM: WriteFile Error
I have been through all of the troubleshooting steps suggested for Simulink Real-Time in the documentation and seeing as I was running this setup perfectly with 2016b with no changes to the target PC or anything else it did not help correct any issues. I have tried using different compilers but to no avail.
I am using a Quanser Q8 PCI board in my target pc.
Edit: I did create a new boot disk for the target PC in Matlab R2017a.

Accepted Answer

Louis Swaidani
Louis Swaidani on 26 Sep 2017
Edited: Louis Swaidani on 26 Sep 2017
The solution if you have the same problem is to make sure you have a hard drive installed on the target PC which was not previously a requirement but is now with R2017a. It believe it is also necessary to reformat the drive with a fat32 partition but have not tested without performing this step first.

More Answers (2)

Michelle Wu
Michelle Wu on 28 Apr 2017
Hi Louis,
I understand that you recently updated Simulink Real-Time from R2016b to R2017a, and now with the same target PC, 'slrttest' fails at Test 4: Build and Download slrttestmdl. I also assume you have performed all the steps listed in the documentation below:
Because you said that you have made no changes to the target PC, my guess is the target kernel version does not match with current MATLAB version. In your case, the target kernel may still be in R2016b while the MATLAB is in R2017a. In other words, the Simulink Real-Time version, which you can find by typing ">> ver('slrt')" in MATLAB Command Window, should match with the target kernel version seen on the target machine screen.
Therefore, please make sure to re-create a boot disk for the target PC in R2017a before running 'slrttest'. For instructions on how to create boot disk, please refer to the following doc page:
Louis Swaidani
Louis Swaidani on 23 May 2017
Edited: Louis Swaidani on 23 May 2017
Apologies I did of course make one change to the target PC which was to update to the new kernel!
So yes I did make a new boot disk (USB drive) in R2017a and the Simulink Real-Time version on the target PC matches that of the development PC. I think this is required to complete tests 1 to 3 succesfully anyway?
When I swich back to the old boot disk (2016b kernel) with MATLAB R2016b everything is working again.

Sign in to comment.

Mohamed Abdelaal
Mohamed Abdelaal on 23 May 2017
Hello, I have exactly the same problem.
Steven Lord
Steven Lord on 12 Jun 2017
Mohamed, Louis, I'm not sure how many people reading Answers will have access to that specific hardware configuration to be able to help you diagnose the problem. I recommend you contact Technical Support using the Contact Us link in the upper-right corner of this page and work directly with the Support staff to determine the cause of this problem.

Sign in to comment.


Find more on Real-Time Simulation and Testing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!