MATLAB Answers

ディープラーニングの​CNNにおけるGPU​使用について

16 views (last 30 days)
Jo Sasaki
Jo Sasaki on 20 Dec 2018
Commented: Jo Sasaki on 21 Dec 2018
CNNにおいてGPUを使用したいのですが、
たたみ込みニューラル ネットワークの GPU サポートには、Compute Capability 3.0 以上の GPU デバイスが必要です。
といったエラーが出ます。
使用しているパソコンのGPUは、
GeForce GTX970M, Compute Capability5.2です。
VERコマンドでは
Neural Network Toolbox バージョン 11.1 (R2018a)
Parallel Computing Toolbox バージョン 6.12 (R2018a)
同じパソコンに入ってるR2017aのMATLABの方ではGPU学習に成功したのですが、trainingOptionのプロパティにおいてどうしてもR2018aの方を使いたいのですが、上記のスペックやバージョンではGPUを使用した計算は可能でしょうか?
  2 Comments
Jo Sasaki
Jo Sasaki on 21 Dec 2018
エラー: gpuDevice (line 26)
グラフィックス ドライバーまたはこの GPU デバイスに問題があります。サポートされている GPU を使用していて、最新のドライバーがインストールされていることを確認してください。
原因:
グラフィックス ドライバーが見つかりましたが、古すぎます。システムのグラフィックス ドライバーは、CUDA のバージョン 8 をサポートしています。必要な CUDA のバージョンは 9以降です
と表示されました。CUDAのアップデートが必要でしょうか?

Sign in to comment.

Accepted Answer

Kei Otsuka
Kei Otsuka on 21 Dec 2018
確認ありがとうございます。
ドライバが古く、GPUが認識されていなかったようです。
NVIDIAさんのサイトから最新のドライバを入手できますので、
アップデートしてから再度お試しください。
  1 Comment
Jo Sasaki
Jo Sasaki on 21 Dec 2018
アップデートしたところ正常に稼働しました
ご回答ありがとうございました。

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!