MATLAB Answers

0

Cannot connect to ROS device

Asked by An Nguyen on 24 Mar 2019
Latest activity Commented on by An Nguyen on 28 Mar 2019
In Ubuntu 16.04, I am building a PID controller model in Simulink and am trying to build and deploy it.
After roslaunching in a terminal which starts up all my other nodes (not built using Simulink), I'm trying to connect my Simulink node to my ROS device by using the IP addr outputted from ifconfig but am failing on this step.
It says that
Cannot connect to device. Check that the device address, username, and password are correct.
I have checked my address, username and password multiple times to ensure they are correct. Please see the photos below for details.
I have tried enabling SSH and disabling the firewall, to no avail.
photo.png
Thank you!

  0 Comments

Sign in to comment.

1 Answer

Answer by Sebastian Castro on 28 Mar 2019
 Accepted Answer

Hi An,
Have you installed openssh-server on your Ubuntu machine? This is needed for the tests to succeed, far as I recall.
- Sebastian

  1 Comment

An Nguyen on 28 Mar 2019
Hi Sebastian,
It turns out the problem was with my machine. I did install openssh-server to enable SSH but it still did not work. I tried the whole process on another machine and it worked out fine. Thank you for looking into this :)

Sign in to comment.