MATLAB hangs on startup at splash screen, possible Java runtime issue (Ubuntu 19.04)

22 views (last 30 days)
Huy Pham
Huy Pham on 31 Aug 2019
Edited: Huy Pham on 11 Feb 2020
I am having a similar problem to the question posted here with a few differences that I can't resolve.
When starting, my whole computer freezes when reaching the splash screen, and CPU usage maxes out. This is persistent if I use the -nodesktop, -nosplash, and -nodisplay options.
MATLAB runs and functions from my terminal when the -nojvm option is used, but this severely limits plotting capabilitiies, and I'd like to use MATLAB without the -nojvm option.
I've tried the solutions here with no success since the test.log created is blank. The accepted answer at this post is not ideal for me, since I need the grub option "nomodeset" to be unused when booting.
My specs are as follows:
OS: Ubuntu 19.04
Processor: AMD Ryzen 5 2500u with radeon vega mobile gfx × 8
Graphics: AMD Raven
I suspect that the combination of the AMD CPU and graphics is forcing the machine to use certain drivers that are incompatible with starting MATLAB, but am entirely unsure.
  6 Comments
FERNANDO Angeles medina
FERNANDO Angeles medina on 26 Dec 2019
I found that BIOS of the motherboard which supports RYZEN processor must be updated to avoid matlab 2019b hangs on startup at splash screen when is running on linux. I did that and the problem was solved. I have a customized machine contening motherboard ASUS-A320M-K, processor AMD® Ryzen 3 2200g with radeon vega graphics × 4, 8GBi RAM, BIOS's version lower than Octuber 2018(which was updated to a more recent 2019/10/30). I had been using Ubuntu 18.04.3 64 bits but after I installed Debian 10 Buster 64 bits without any problem.

Sign in to comment.

Accepted Answer

Huy Pham
Huy Pham on 9 Feb 2020
Edited: Huy Pham on 11 Feb 2020
@Fernando Angeles Medina THANK YOU my MAN. This solution worked for me.
I am using Ubuntu 19.10 and I updated/flashed my BIOS to Lenovo's latest release for my Laptop (November 2019). I am then able to boot MATLAB normally.
Thanks everyone!
Referenced post:

More Answers (1)

JOHAN AUGUSTO BOCANEGRA CIFUENTES
Hi, I have a similar problem with UBUNTU 19.10, I can only see the startup logo and then chrash.
I solve the problem running all updates related with JAVA from synaptic.
Hope works for someone else.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!