matlab.gra​phics.illu​stration.L​egend/set

18 views (last 30 days)
Ewan Hislop
Ewan Hislop on 23 Oct 2019
Commented: Ewan Hislop on 24 Oct 2019
Hi, I was wondering if anyone could help me get past this error using matlab to create a graph?
There appears to be an issue with setting the legend and I'm not sure how to fix this
Many thanks in advance!
Screenshot 2019-10-23 at 11.51.37.png

Answers (2)

Luna
Luna on 23 Oct 2019
Edited: Luna on 23 Oct 2019
Hello,
Try this,
legend_h = legend('TOFA (5uM)... ...');
set(legend_h,'Color','none','...','...');
It seems you have forgotten a comma between name/value pair argument. ('Color', 'none')
  1 Comment
Ewan Hislop
Ewan Hislop on 23 Oct 2019
Sorry yes even with a comma inserted in my original script, I get the same error unfortunately.
I attempted your suggestion (legend_h) and I get the same error also :(
Thanks :)

Sign in to comment.


Steven Lord
Steven Lord on 23 Oct 2019
The legend object does not have a property named Blue.
If you're trying to change the colors of the objects listed in the legend, change the Color properties of those objects. You can't change them via the handle returned from legend as far as I am aware.
  1 Comment
Ewan Hislop
Ewan Hislop on 24 Oct 2019
Thanks for all the help...
I appeared to have solved the issue by deleting the set legend data line.
Cheers :)

Sign in to comment.

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!