MATLAB Answers

OSError: MATLAB Engine for Python supports Python version 2.7, 3.5 and 3.6 but your version of Python is 3.7

16 views (last 30 days)
JSO CI Team Veoneer
JSO CI Team Veoneer on 27 Mar 2020 at 7:14
Answered: Steven Lord on 27 Mar 2020 at 13:19
We recently installed Python 3.7.2.
Matlab engine was working with the earlier 2.7, but now when we try installing the engine, getting the below error.
"OSError: MATLAB Engine for Python supports Python version 2.7, 3.5 and 3.6 but your version of Python is 3.7"
Although, Matlab supported versions indicates that 3.7 is supported, the "setup.py" does not seem to have 3.7 in the supported versions.
Where can I download the latest setup.py.
Is modifying the setup.py to include 3.7 sufficient ?

  0 Comments

Sign in to comment.

Accepted Answer

Steven Lord
Steven Lord on 27 Mar 2020 at 13:19
Support for Python 3.7 was added in release R2019a. The Release field to the right of this question indicates you're using release R2018b, one release prior to that.

  0 Comments

Sign in to comment.

More Answers (0)

Sign in to answer this question.

Products


Release

R2018b