Which Xilinx Vivado edition do I need to install for use with HDL Coder, HDL Verifier, or other HDL-related toolboxes?

120 views (last 30 days)
I am trying to install Xilinx Vivado as a synthesis tool for use with HDL Coder, HDL Verifier, or other HDL-related toolboxes such as SoC Blockset or Deep Learning/Vision/Wireless HDL Toolbox. After launching the Xilinx web installer, I can select between the following three Vivado editions:
  • Vivado HL WebPACK
  • Vivado HL Design Edition
  • Vivado HL System Edition
Which edition do I need to install for use with HDL Coder or HDL Verifier?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 8 Oct 2021
Edited: MathWorks Support Team on 8 Oct 2021
All three Vivado editions mentioned above will work with our products.
Usually, either the WebPACK or Design Edition of Vivado will be sufficient. Which of the two editions you need depends on the FPGA device that you are targeting:
Xilinx products that are not required for our workflows include "Model Composer", "System Generator for DSP", and "Vivado HLS".
Note that Vivado Lab Edition is not supported.
To find out which Vivado version number is supported with each MATLAB release, please refer to the following MATLAB Answers post: Which versions of Xilinx Vivado are supported with which release of HDL Coder?

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!