Request for clarification on support GCC version for matlab on Linux

6 views (last 30 days)
Wes
Wes on 4 May 2020
Commented: Sai Sri Pathuri on 12 May 2020
It mentions that for release 2019a supported versions of GCC are 6.3.x, are newer versions supported? Or only 6.3.x?
I am asking because I am upgrading GCC on a CentOS 7 system and would like to build the newest version of GCC if possible.
Thanks!

Answers (1)

Sai Sri Pathuri
Sai Sri Pathuri on 9 May 2020
We claim gcc 6.3 as the officially supported compiler because it is the version we thoroughly qualified. That being said, other versions of gcc should work in general. The only difference is that MEX command issues a warning if a unsupported gcc compiler is being used. You may suppress the warning by using the warning command if you would rather not utilize the particular gcc version.
  2 Comments
Sai Sri Pathuri
Sai Sri Pathuri on 12 May 2020
Yes, you may ignore the warning.
If you don't want the warning to be shown, you may use
warning('off',warnId)
You may use lastwarn after mex compilation to get the warning identifier
[msgStr,warnId] = lastwarn
You may refer the following link for similar answer

Sign in to comment.

Products


Release

R2019a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!