MATLAB Answers

New User Thingspeak data

1 view (last 30 days)
Alan Pedder
Alan Pedder on 8 May 2021
Commented: Alan Pedder on 14 Jul 2021
Hi I am new to IoT and have just set up a Cricket module which is transmitting "temp" and Battery data to Thingspeak and is showing a number of entries but they are not displaying any values
  1 Comment
Alan Pedder
Alan Pedder on 8 Jul 2021
I have it working by using GET (which seems counter intuitive) and adding fields and not using payload. But like yourself perhaps I followed the article in PE but after several attempts thier route just did not work for me.

Sign in to comment.

Answers (3)

Malcolm Hood
Malcolm Hood on 8 Jul 2021
Hi I am having the same problem - have checked my setup numerous times with no sucess - cricket is sending data but appears not to be received

Christopher Stapels
Christopher Stapels on 13 Jul 2021
Can either of you share your channel ID if they are public? Then we can have a look at the data you are sending and see what is happening.

Alan Pedder
Alan Pedder on 13 Jul 2021
hi
This is my channel I just made public ID 1391895 Author stoicped.
its got a pretty useless moisture sensor attached with limited range.
hope this helps
  4 Comments
Alan Pedder
Alan Pedder on 14 Jul 2021
I was not the one with the problem Christopher. I had the same problem but solved it. The Cricket seems to be the problem in using its payload data sending method. I followed the Practical Electronics instructions to the letter and the result was the data seemed to arrive as the 'count' showed on ThingSpeak but no data was displayed graphically. So I suspect ThingSpeak was receiving an empty file.

Sign in to comment.

Communities

More Answers in the  ThingSpeak Community

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!