Clear Filters
Clear Filters

MATLAB を "最小" または "コア" の Linux インストールにインス​トールするには、どの​ような依存関係が必要​ですか?

12 views (last 30 days)
MathWorks Support Team
MathWorks Support Team on 5 Apr 2024
Linuxの「最小」または「コア」インストールがあり、MATLABをインストールしたいと思います。そのためには、どのような追加の依存関係が必要ですか?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 9 Apr 2024
Edited: MathWorks Support Team on 9 Apr 2024
MATLAB と Simulink は、システム要件ページに記載されているディストリビューションの標準インストールで検証されています。Linux の「最小」または「コア」インストールには、MATLAB および Simulink のインストールと実行に必要なソフトウェアパッケージが不足している可能性があります。必要なソフトウェアパッケージを最小限のLinux インストールに追加できますが、テクニカルサポートは制限されます。
MATLAB R2019b 以降の Ubuntu に必要な依存関係は、matlab-deps Docker イメージのbase_dependencies.txtで確認できます。MATLAB R2021b 以降には、Ubi8 用のこのテキスト ファイルが追加されています。これは、次のページにあります:
ページの左側にある [ファイル] で、目的のリリースを選択し、次にオペレーティング システムを選択します。次に、[base_dependencies.txt]をクリックして、必要な依存関係を表示します。
Linux コマンドを使用して、ライブラリの依存関係をインストールできます。たとえば、R2024a に必要なライブラリをすべて Ubuntu 22.04 にインストールするには、次のコマンドを実行します。
sudo apt-get install ca-certificates libasound2 libc6 libcairo-gobject2 libcairo2 libcap2 libcups2 libdrm2 libfontconfig1 libgbm1 libgdk-pixbuf-2.0-0 libgl1 libglib2.0-0 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libice6 libltdl7 libnspr4 libnss3 libpam0g libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libsndfile1 libudev1 libuuid1 libwayland-client0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxrandr2 libxt6 libxtst6 libxxf86vm1 locales locales-all make net-tools procps sudo unzip zlib1g
上記のコマンドでリストされているライブラリは、このページから取得されました:
matlab-deps/r2024a/ubuntu22.04/base-dependency.txt

More Answers (0)

Tags

No tags entered yet.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!