MATLAB Answers

0

Pixhawk PX4 PSP installation errors

Asked by Mahmud Khan on 30 Jan 2019
Latest activity Edited by Mahmud Khan on 5 Apr 2019
I tried to download the PX4 support package for Embedded Coder from here and install it.
I followed the instructions given, created c:\px4 directory and ran the command PixhawkPSP('c:\px4') on Matlab and got this:
mlb1.png
The instructions on that page told me to then click "Save serttings and Exit" and I did that and got the following errors:
mlb2.png
And on my Matlab console, this is what I got:
mbl3.png
What just happened? How do I resolve this problem?

  2 Comments

I had the same issue as you noticed HERE.
I managed to build the firmware from my ubuntu terminal, but it still doesn't build from the User interface provided with the PSP. I was also able to compile/build the rgb_led.slx example and flash to the pixhawk. Then enabled the PSP by starting the px4_simulink_app via nsh. Just for testing.
I am yet to try out the setup on Windows, and will do soon.
Hope this helps someone.
I am working on Windows and my installation crashed and burned as you saw from the screenshots.
In this day and age, one would think that there'd be detailed guides/video tutorials on the matter.
Thanks for responding.

Sign in to comment.

Products


Release

R2017a

1 Answer

Abhishek GS 님의 답변 2 Apr 2019

The official support package 'Embedded Coder Support Package for PX4 Autopilots' is now available from R2018b onwards.
Uninstall the Pixhawk PSP, if you have it installed and refer the documentation on getting started with the official support package.
The above mentioned issues should be solved.
~Abhishek

  3 Comments

Thanks for the update Abshishek.
@Abhishek GS
I wasn't using R2018b!
I use R2017b. Is this new one compatible with my release of Matlab? Given that this new version uses GCC 7.2.1, if it works with R2017b, then my compatibility issues will get resolved immediately.
Hi Mahmud,
As I have mentioned above, the official support package 'Embedded Coder Support Package for PX4 Autopilots' is now available from R2018b onwards. It is not compatible with R2017b.
Thanks

Sign in to comment.